Archiv

Kategorien

Mehr als 0 und 1

Letzte Postings

Tweets

für gesamten Blog

Wenn die Wolkenbox den Fritz nicht mag - dann liegts an UPNP-IGD/NAT-PMP (Update)

25 Sep 2014 - 01:49 | Version 14 |

Disclaimer: Inhalt technisch und kurzlebig. Hilfe erbeten von Leuten, die DHCP erklären und V92 pfeifen können wink

Anfang Jahr hatte ich mir eine grössere Netzwerkfestplatte (eine Lacie Cloudbox 3TB) gekauft, um das übliche Jahresbackup zu machen und das bisherige NAS ausser Haus zu lagern.

cloudbox01.jpg

Laut Anleitung hat die Box zu Beginn bis zu 10 Minuten zum Initialisieren und sollte danach dauerhaft blau leuchten. Dummerweise hat mein Exemplar ca. 20 Minuten blau geblinkt und danach rot geleuchtet. #grummel Also nachschauen, was das bedeutet:

cloudbox02.jpg

Gut, resetten und wieder 20 Minuten warten. Gleiches Resultat. #grummel2

Die Cloudbox kriegt eine IP-Adresse, reagiert auf Pings und reagiert die ersten 20 Minuten sogar auf http-Anfragen, allerdings immer mit der gleichen Antwort: "your device may be powering on."

Am nächsten Tag im Büro an einem anderen Router ohne Internet-Anschluss versucht. Funktioniert, leuchtet brav blau. Nach Hause genommen, angeschlossen, 20 Minuten gewartet. Rot. #grummel3

Support-Ticket bei Lacie eröffnet, Problem geschildert. Antwort von Lacie:

In ihrem Fall liegt wahrscheinlich ein Hardwaredefekt vor, welchen wir ihnen im Rahmen ihrer Garantie beheben werden.

Bitte wenden Sie sich zur Überprüfung bzw. Reparatur an Ihren Händler, von dem Sie das Gerät erworben haben.

Cloudbox ins Geschäft zurückgebracht. 14 Tage gewartet. Gerät wieder abgeholt. Antwort Reparaturservice: "Bei uns läuft das Gerät einwandfrei. Es muss an ihrer Konfiguration liegen".

Tatsächlich: Gerät nach Hause genommen, angeschlossen. 20 Minuten gewartet. Rote LED. Gerät an anderen Router (ohne Internet) angeschlossen: Funktioniert. #grummel4

Gegooglet nach lacie cloudbox fritzbox. Resultat:

Hallo,
ich habe mir eine Lacie Cloudbox und an meine Fritzbox angeschlossen aber ich bekomme die zwar in der Fritzbox zu sehen kann aber nicht zugreifen die blinkt immer Blau schon mehrmals die Cloudbox redetet aber nichts. Muss ich was bestimmtes in der Fritzbox einstellen damit die geht ???
Danke schonmal
Gruß
Didi

OK, die Cloudbox scheint die Fritzbox nicht zu mögen. Und jetzt? An meiner Fritzbox hängt bereits seit langem eine älteres Lacie NAS, eine Lacie Space. Die kann es offenbar mit der Fritzbox, nicht aber die neue.

Woran könnte es liegen?
  • Gigabit-Anschluss?
  • Dass es bereits eine Lacie im Netz hat (habe ich allerdings auch mal abgeklemmt)
  • IPV6? (Meine aber, alles derartige auf der Box deaktiviert zu haben).
  • Weitere Vorschläge?

Problem gelöst (bzw. eingegrenzt)

Tja, als Informatiker konnte ich es nicht lassen und habe - nachdem ich rausgefunden hatte, wie ich dran komme - angefangen die Logfiles der Cloudbox zu studieren. Das hat mich dann zur Lösung gebracht:

Die Wolke und der Fritz verstehen sich prächtig, wenn man entweder die IP-Adresse der Cloudbox manuell einstellt (also auf DHCP verzichtet) oder dann die automatische Port-Weiterleitung deaktiviert:

cloudbox03.jpg

Ich erklär mir's so: Die Cloudbox möchte mit Fabrikeinstellungen dem Fritz sagen, er solle doch gewisse Ports automatisch an die Cloud umbiegen, damit die Cloudbox aus dem Internet erreichbar ist. Der Fritz stellt sich aber (berechtigterweise) stur ("da könnte ja jeder kommen und sagen, was ich wohin routen muss! Wer ist da der Router??") und verweigert das. Die Cloudbox gibt sich darüber so beleidigt, dass sie 3 Mal rebootet und danach die rote Fahne - äh LED - rauslässt.

So, liebe LaCie, jetzt fixt das mal mit der nächsten Firmware...

Hier noch etwas technischer:

Aus dem Logfile unicorn_core.log beim Booten an der Fritzbox, beim Versuch Port Forwarding zu aktivieren:
Jan 22 14:58:50 wolke [INFO __init__.upnp_discovering@205] 2 UPnP device(s) detected in 250 ms
Jan 22 14:58:50 wolke [INFO __init__.upnp_discovering@220] UPnP: Internet Gateway Device found: http://192.168.1.1:49000/upnp/control/WANIPConn1
Jan 22 14:58:50 wolke [DEBUG resource.set@484] Setting config value unicorn.network.port_mapping.protocol to [UPnP-IGD]
Jan 22 14:58:51 wolke [INFO __init__.upnp_discovering@205] 2 UPnP device(s) detected in 250 ms
Jan 22 14:58:51 wolke [INFO __init__.upnp_discovering@220] UPnP: Internet Gateway Device found: http://192.168.1.1:49000/upnp/control/WANIPConn1
Jan 22 14:58:51 wolke [INFO __init__.toggle_port_mapping@469] Set up UPnP-IGD rule: port 443
Jan 22 14:58:58 wolke [INFO __init__.init@123] Initializing unicorn...
Exakt nach dem Logfile-Eintrag der versuchten Portweiterleitung via UPnP-IGD startet die Cloudbox neu...

Und so sieht das an einem anderen Router aus:
Jan 22 15:51:18 wolke [INFO __init__.upnp_discovering@205] 1 UPnP device(s) detected in 250 ms
Jan 22 15:51:19 wolke [INFO __init__.upnp_discovering@220] UPnP: Internet Gateway Device found: http://192.168.1.1:80/wpppc_cont
Jan 22 15:51:19 wolke [INFO __init__.upnp_discovering@226] UPnP-IGD: This IGD cannot be used for port forwarding
Jan 22 15:51:19 wolke [ERROR libnatpmp.get_natpmp_server@187] NAT-PMP: failed to get gateway's public address [NATPMP_ERR_NOGATEWAYSUPPORT: the gateway does not support NAT-PMP]
Jan 22 15:51:19 wolke [DEBUG resource.set@484] Setting config value unicorn.network.port_mapping.protocol to []
Jan 22 15:51:19 wolke [INFO __init__.toggle_port_mapping@438] toggle_port_mapping REMOTE_ACCESS
Jan 22 15:51:19 wolke [INFO __init__.toggle_port_mapping@438] toggle_port_mapping TORRENT
Jan 22 15:51:19 wolke [INFO __init__.toggle_port_mapping@438] toggle_port_mapping SFTP
Jan 22 15:51:19 wolke [INFO __init__.toggle_port_mapping@438] toggle_port_mapping FTP
Hier stürzt die Cloudbox nicht ab, sondern kommt im Bootprozess weiter.

Problemlösungen bis zum nächsten Firmwareupdate von LaCie

Wie lässt sich das Problem denn nun kurzfristig lösen?

  • Man lässt in der Fritzbox UPNP zu:
    • Entweder für immer
    • oder bis man in der Cloudbox eine statische IP eingestellt hat
  • Man nutzt temporär einen anderen Router um in der Cloudbox eine statische IP-Adresse einzustellen
  • Man schliesst die Cloudbox direkt mit einem Ethernetkabel an den eigenen Computer, um danach der Cloudbox eine statische IP-Adresse zu geben (ungetestete Lösung)

Das nächste Problem: Bei mir lässt sich SFTP nicht aktivieren. Der Support meint lapidar, bei ihnen im Labor würde es funktionieren, ich solle doch die aktuellste Firmware installieren und die Box frisch aufsetzen. Nein danke, mit der Box-Installation habe ich schon zu viel Zeit verbracht...

-- BeatDoebeli - 09 Feb 2013

genau das war auch mein Problem. danke für die hilfe

-- HugoM - 23 Mar 2013

genau das war auch mein Problem. danke für die hilfe

-- HugoM - 23 Mar 2013

Ich hatte dasselbe Problem und konnte es mit diesem Beitrag lösen. Vielen Dank dafür. Vom LaCie-Support kam bisher keinerlei sinnvolle Info zu diesem Problem.

Jetzt habe ich noch ein weiteres Problem mit der Cloudbox: die Zeitsynchronisation geht nicht. Hat da vielleicht noch jemand eine Idee dazu? Wäre super, wenn ich das auch noch lösen könnte.

Gruß, Martin

-- MartinThanheimer - 23 Apr 2013

Vielen Dank für diesen hilfreichen Tipp. Ich dachte schon, ich hätte mich verkauft – trotz der positiven Tests in den einschlägigen Magazinen.

-- CarstenSchmittmann - 14 Jun 2013

Was mich an dieser Sache erstaunt: LaCie scheint die Firmware noch immer nicht angepasst zu haben, wie die vielen Zugriffe auf diesen Blogeintrag hier zeigen.

-- BeatDoebeli - 15 Jun 2013

-- RuttnerC - 14 Aug 2013

Ich konnte heute exakt das gleiche Verhalten bei einer Lacie-2big-nas nachvollziehen! Gestern initialiseirt - ewig langes Blau Blink, dann Rot - Heute in der Firma initialisiert, alles nach Plan! - zu Hause angesteckt - wieder nur Blau Blink - An der Fritz Box 7390 UPnP unter "Heimnetz - Netzwerk - Programme" abgestellt - Lacie gebootet - funktioniert. Anmerkung: Für den Internetzugang habe ich eine Cisco ASA die auch DHCP durchführt. Es scheint so, als ob sich die Fritz!Box über UPnP meldet, und Lacie unbedingt von dort in das Internet möchte.

-- RuttnerC - 14 Aug 2013

Herzlichen dank für die Informationen. Ich bin nach dieser wie folgt vorgegangen:
> Cloudbox direkt an Mac angeschlossen; IP-Adresse zugewiesen; Häkchen bei automatischer Weiterleitung rausgenommen
Somit läuft das Teil gut im Netzwerk als NAS. Soda hatte ich aber schon zuvor mit dem WirelessSPace von Lacie. Jetzt wollte ich die Wolkenapp auf dem Iphone und ipad nutzen. Beim anmelden der Cloudbox bei MyNAS gibt's aber eine Fehlermeldung: Der Zugriff auf den Fernzugriffsserver ist nicht möglich. Bitte bestätigen Sie, dass Ihr CloudBox Zugang zum Internet hat. Überprüfen Sie ggf. die DHCP-, Router- und Proxy-Einstellungen" Welche Freigabe bracuht die CloudBox und wie kann ich ihr diese in der FritzBox gewähren? Viele Grüße Jan

-- JanL - 09 Feb 2014

Many thanks for this information - this described my problem exactly - Cloudbox working normally with old gateway, not working with new Fritz 7490.Simply disabling Cloudbox's automatic port forwarding did the trick. Oh and I changed the cloudbox's static IP as well but pretty sure I didn't need to. Wunderbar! Herzlichen Dank!

-- CrimemasterGogo - 25 Sep 2014
 
Zum Kommentieren ist eine Registration notwendig.

Kategorien: IsaBlog, IsaGeek, IsaAnnoyance